PDA

View Full Version : Did I kill my new vallisnerias?



Alfcea
04-21-2009, 02:06 AM
Hello everyone!

Just one quick question about the corkscrew vals that I got yesterday...

Every time I get new plants, I disinfect them with potassium permanganate to avoid introducing nasty things into my tank, and I've never had any problems with this... so, I put my new vals in the permanganate bath and when I took them out a couple of hours later, they were brown. They don't look like they are rotting (yet!), and I am hopeful they will eventually perk up... but I am not sure. I know that vals are very sensitive to chemicals like copper, excel, bleach and others... did I kill them?

Thanks!

Lady Hobbs
04-21-2009, 02:54 AM
I have killed my vals now twice with peroxide which is supposed to be far less harsh than the permanganate. Excel kills them too and need half doses. Touchie plant.

Alfcea
04-21-2009, 03:20 AM
Well... (sigh)... I guess that's it, then.... At least, now I know better....

Zilla
06-02-2009, 01:31 AM
Why did you leave them soaking for a couple of hours?

I've gotten two batches of Vals from two different sources and gave them a PP bath for 20 minutes each. Once the inital bath was done, I emptied the bucket, refilled with clean water and Prime, then let them soak again for another 20 minutes to deactivate the PP.

Once that was finished and I gave the plants a good visual look over, I put them in my tank and haven't had any problems with unwanted critters or dead plants.

It doesn't take hours for the PP to kill snails or otherwise.

Alfcea
06-02-2009, 06:13 PM
Oh! I had already forgotten about this thread! It is a few weeks old...

... and you may be happy to know that they have perked up! For a while, they looked like they were dead, but I still left them in the tank... then they were uprooted and left them floating next to the light... and they eventually started growing back! I was so happy! Last week, I planted them on the grave again, and, though they haven't grown much since then, they are, at least, not dead... :19: yay!

troy
06-02-2009, 06:18 PM
That's great news Alfcea.

MCHRKiller
06-02-2009, 07:09 PM
Glad your Vals perked up for ya :22: I all but killed mine in a routine 1:20 bleach solution for less than 5minutes to kill some filament algae...the roots survived as I didnt dip that part and they are slowly growing back. Vals are picky little things.

bushwhacker
10-28-2009, 09:59 PM
i buy almost all of my plants from members of the forums, i rarely ever need to treat for pests as they will tell me if there are snails or such in their tanks. all my vals come from a lady in san francisco and i know those are clean... and yes they are touchy plants