I didn't see the "yes, but not in recent memory" option