Aquarium Forum
 


Menu
  · Tropical Fish Home
· Fish News
· Aquarium Forum
· Buy & Sell
· Calculators
· Equipment reviews
· Free Aquarium Ebook
· Feedback
· Link to us
· Photo gallery
· Plant species
· Tropica Plant DB
Tropical fish species
· By Common name
· By Scientific name
Tropical Marine fish
· By Common name
· By Scientific name

_________________
 
      
        Via paypal

  AC news is a part of
      Nature Blog Network

      Reef Aquarium Blog

Privacy & Ad Policy

Articles
  · African Cichlids
· Algae Control
· Aquarium Decoration
· Aquarium Resources
· Aquatic Plants
· Barb Fish
· Betta Fish
· Breeding Fish
· Catfish
· Central American Cichlids
· Cichlids
· Clownfish
· Corals
· Corydoras Catfish
· Discus Fish
· Dwarf Cichlids
· Fish Diseases
· Frogs and Turtles
· Goby Fish
· Goldfish
· Gourami
· Invertebrates
· Jellyfish
· Killiefish
· Lake Victoria Cichlids
· Livebearers
· Malawi Cichlids
· Marine Aquariums
· Marine Aquarium Fish
· Other Fish
· Pleco
· Predatory Fish
· Photography
· Pond Fish
· Responsible Fish Keeping
· Rainbow Fish
· Shark Fish
· South American Cichlids
· Tanganyika Cichlids
· Tetra Fish
· Tropical Fish Food
Results 1 to 5 of 5
  1. Default Problem with internal power filter


    0 Not allowed!
    I just set up my aquarium along with a Boyu SP-1000A internal filter..
    But my filter is not working...
    Last edited by Lady Hobbs; 01-01-2011 at 01:44 PM.

  2. #2

    Default


    0 Not allowed!
    Moved your post to technical.

    Did you fill the filter with water so it could prime? Is the stem seeded down properly onto the impeller?

  3. Default


    0 Not allowed!
    Quote Originally Posted by Lady Hobbs
    Moved your post to technical.

    Did you fill the filter with water so it could prime? Is the stem seeded down properly onto the impeller?

    I am not very familiar with the working of this filter....http://www.aquaticcommunity.com/aqua...sblue/scry.gif
    Could you please tell me right process for running this type of filter....
    I tried searching this topic on net but couldn't find a satisfying answer

    Thnq

  4. #4

    Default


    0 Not allowed!
    Ok, we're looking at a power head that has as the intake, a filter media of some sort with a perforated "solid" core that the power head connects to. Around the filter media is a slotted plastic housing to keep largish stuff from being sucked against the media.

    On any power head, the usual reason for it not working is gunk, gravel, or a bit of excess plastic blocking the impeller assembly from spinning. Un-plug the filter and start taking it apart until you can pull the impeller assembly and find out what is blocking it. Remove that.
    Unless the unit is dead, all should work after you re-assemble it.

  5. #5

    Default


    0 Not allowed!
    Good thinkin' there dbosman. Perhaps there is some packing material in there still.

    forreal......not sure why you are posting links to smileys. If you simply click on the blue "post reply" button under the posts, you will have your smileys right here without having to add links.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •