Aquarium Forum
 


Menu
  · Tropical Fish Home
· Fish News
· Aquarium Forum
· Calculators
· Free Aquarium Ebook
· Feedback
· Photo gallery
· Plant species
· Tropica Plant DB
Tropical fish species
· By Common name
· By Scientific name
Tropical Marine fish
· By Common name
· By Scientific name

Articles
  · African Cichlids
· Algae Control
· Aquarium Decoration
· Aquarium Resources
· Aquatic Plants
· Barb Fish
· Betta Fish
· Breeding Fish
· Catfish
· Central American Cichlids
· Cichlids
· Clownfish
· Corals
· Corydoras Catfish
· Discus Fish
· Dwarf Cichlids
· Fish Diseases
· Frogs and Turtles
· Goby Fish
· Goldfish
· Gourami
· Invertebrates
· Jellyfish
· Killiefish
· Lake Victoria Cichlids
· Livebearers
· Malawi Cichlids
· Marine Aquariums
· Marine Aquarium Fish
· Other Fish
· Pleco
· Predatory Fish
· Photography
· Pond Fish
· Responsible Fish Keeping
· Rainbow Fish
· Shark Fish
· South American Cichlids
· Tanganyika Cichlids
· Tetra Fish
· Tropical Fish Food

User Tag List

Results 1 to 1 of 1
  1. #1

    Join Date
    May 2020
    Posts
    3

    Latest gifts & ribbons:

    Default Need help getting rid of some brown algae pls!


    0 Not allowed!
    hello there....

    I have been struggling with some brown algae problem for a while now I can't seem to shake it off. what I've done from the beginning, sorry for the length but figured more info would be better.

    I have a 75gal planted tank. I started this tank with pool sand. then made it 50/50 sand and substrate. stayed like this for a while and eventually got the brown algae. Then I read somewhere about the diatoms and how pool sand feeds them because of the silica I believe. So I recently removed the sand and now I have a mixture of some of the old black substrate and 3 new bags of CaribSea Eco complete coarse substrate. Pretty much all the plants in the tank are all new with the substrate as well.

    I was doing DIY CO2 but just switched today to compressed tank at 3 bubbles / sec with solenoid
    Fluval CO2 indicator (always green)
    Seachem Root Tabs (just put them in 2 days ago)
    2 - Eheim 350 canister filters (1-2 times a month cleaning)
    Finnex 24/7 planted light and Aquatic Life LED light
    2 small pumps (top back left and front bottom right) for water movement (bottom right pushing CO2)
    30%-35% water changes twice a week
    7ph (maintaining with Seachem Neutral Regulator)
    10ppm-20ppm Nitrates (was at 80ppm before I got rid of pool sand. now its at 10-20ppm)
    Nitrites and Ammonia are good


    Why 2 lights? on fell in the water and stopped working so I ordered another one. But then it started working again. So I read something about having enough lighting for the CO2 and Root Tabs to keep up with the nutrients so the plants would win the feeding against the algae. Needless to say I fell into a very deep rabbit hole in lighting, amongst other things... I keep them on for around 10 hours. both lights are on from 12pm-8pm. low blue light during the night time.

    I am definitely seeing an explosion in growth, lots of pearling, beautiful bright greens. But then it starts to turn brown. I can't think of anything else to do at this point. ANY suggestions are EXTREMELY welcomed

    hopefully the pics will show enough.

    Thanks!!
    Attached Images Attached Images

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •