Aquarium Forum
 


Menu
  · Tropical Fish Home
· Fish News
· Aquarium Forum
· Buy & Sell
· Calculators
· Equipment reviews
· Free Aquarium Ebook
· Feedback
· Link to us
· Photo gallery
· Plant species
· Tropica Plant DB
Tropical fish species
· By Common name
· By Scientific name
Tropical Marine fish
· By Common name
· By Scientific name

_________________
 
      
        Via paypal

  AC news is a part of
      Nature Blog Network

      Reef Aquarium Blog

Privacy & Ad Policy

Articles
  · African Cichlids
· Algae Control
· Aquarium Decoration
· Aquarium Resources
· Aquatic Plants
· Barb Fish
· Betta Fish
· Breeding Fish
· Catfish
· Central American Cichlids
· Cichlids
· Clownfish
· Corals
· Corydoras Catfish
· Discus Fish
· Dwarf Cichlids
· Fish Diseases
· Frogs and Turtles
· Goby Fish
· Goldfish
· Gourami
· Invertebrates
· Jellyfish
· Killiefish
· Lake Victoria Cichlids
· Livebearers
· Malawi Cichlids
· Marine Aquariums
· Marine Aquarium Fish
· Other Fish
· Pleco
· Predatory Fish
· Photography
· Pond Fish
· Responsible Fish Keeping
· Rainbow Fish
· Shark Fish
· South American Cichlids
· Tanganyika Cichlids
· Tetra Fish
· Tropical Fish Food
Page 1 of 3 123 LastLast
Results 1 to 10 of 27
  1. Default Filstar Rena Xp3 question


    0 Not allowed!
    I've had my xp3 for 2 weeks now and I've got a problem. The first week or so it was running almost silently then started making a humming noise coming from the motor house. I took it apart and cleaned everything after I put it back together the lever to control the flow was stuck in the siphon off position. I took off the part that connects the intake/out take tubes to the canister and it seems to be stuck with something. I've tried to clean it and it appears to be a gum of some sort, no idea how it got there. I've tried to call rena but no response yet... Here's a picture DSC08886_zps10ee7c49.jpg

    any idea on what it could be and how to get rid of it?
    20 gallon tall: empty
    29 gallon: moderately planted with 9 bloodfin tetra, 1 german blue ram, 11 glow light tetra and 1 BNP
    10 gallon QT: empty

  2. #2

    Default


    0 Not allowed!
    That, my good friend, is the grease to prevent water leaking at the seams. Don't take that stuff off. You can replace it with some aquarium-safe (or food-grade) lubricant/grease, though.

    As for re-inserting this piece... you need to push down on it, before you bring the lever back. There's a safety mechanism which prevents it from being pulled into the on-position, before it being in-place in the filter. Easiest way I've found is just pushing down on the two sides w/ one hand and pulling the lever back with the other.

    If you find that it's broken, you can replace it for free. Just e-mail them at their support page and they'll hook you up. Great customer service.
    Adventures in Aquaria - The KevinVA Story

    When in doubt, ask yourself... W.W.L.S (What would Lee Say)?

    Have a fish problem? Fill out and post this completed questionnaire in the General Aquarium Forum, when you start a new thread.

  3. Default


    0 Not allowed!
    Thanks Kevin! I was wondering what that was. I wasn't pushing down on it I'll try again and see if it works. Any ideas on how to reduce the humming noise?
    20 gallon tall: empty
    29 gallon: moderately planted with 9 bloodfin tetra, 1 german blue ram, 11 glow light tetra and 1 BNP
    10 gallon QT: empty

  4. #4

    Default


    0 Not allowed!
    What kind of humming? Was it an air bubble noise, as if there was a leak somewhere? Does it have a constant noise and then it stops abruptly and restarts again?
    Adventures in Aquaria - The KevinVA Story

    When in doubt, ask yourself... W.W.L.S (What would Lee Say)?

    Have a fish problem? Fill out and post this completed questionnaire in the General Aquarium Forum, when you start a new thread.

  5. Default


    0 Not allowed!
    It's the motor running no other way to describe it. I've tried everything I can think off to get it less noisy. If I can't return it I'm just going to sell it and get an AC70 I'm tired of messing with it and I already know the AquaClear filters.
    20 gallon tall: empty
    29 gallon: moderately planted with 9 bloodfin tetra, 1 german blue ram, 11 glow light tetra and 1 BNP
    10 gallon QT: empty

  6. #6

    Default


    0 Not allowed!
    Well, if you listen carefully, every canister has a humming noise... some louder than others. Might be yours is functioning correctly. How loud is it? Might be a bad motor or impeller if it's really loud... ya never know, until you start replacing parts.
    Adventures in Aquaria - The KevinVA Story

    When in doubt, ask yourself... W.W.L.S (What would Lee Say)?

    Have a fish problem? Fill out and post this completed questionnaire in the General Aquarium Forum, when you start a new thread.

  7. Default


    0 Not allowed!
    I've emailed rena about the hose connector after I've got a new piece I'll see about a replacement motor. Its louder then then the motor in my ac30 and still noticeable with people talking in the room.
    20 gallon tall: empty
    29 gallon: moderately planted with 9 bloodfin tetra, 1 german blue ram, 11 glow light tetra and 1 BNP
    10 gallon QT: empty

  8. #8

    Default


    0 Not allowed!
    I absolutely LOVE my XP filters. Is there air in the filter? Try rocking it back and forth - see if that gets the air out. Once they are full they are silent, but I find the noise they make when there is air inside to be quite annoying.
    125 - BGK, pictus cats, silver dollars, kissing gouramis, palmas bichir, delhezi bichir
    125 - Red severum, bolivian rams, Turquoise rainbows, irian red rainbows, loaches (angelicus, zebra, kuhli and horseface), plecos (BN, RL and clown), denison barbs, pearl gouramis
    90 - Congo tetras, african knife, elephant nose, spotted ctenopoma, upside down cats

    QTs - 29, 20H, 20L, 10

  9. #9

    Default


    0 Not allowed!
    I have 3 rena xp3's, they are really quiet. Just hear them humming if I kneel down close to it. Trapped air may be causing the problem like others suggested. Shaking the canister while it's running may help dislodge the air.

  10. Default


    0 Not allowed!
    I tried multiple times before the top part apparently broke. When I get a replacement or figure the problem out I'll restart it and see if I can get it silent.
    20 gallon tall: empty
    29 gallon: moderately planted with 9 bloodfin tetra, 1 german blue ram, 11 glow light tetra and 1 BNP
    10 gallon QT: empty

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •