Aquarium Forum
 


Menu
  · Tropical Fish Home
· Fish News
· Aquarium Forum
· Calculators
· Equipment reviews
· Free Aquarium Ebook
· Feedback
· Link to us
· Photo gallery
· Plant species
· Tropica Plant DB
Tropical fish species
· By Common name
· By Scientific name
Tropical Marine fish
· By Common name
· By Scientific name

_________________
  ...

Articles
  · African Cichlids
· Algae Control
· Aquarium Decoration
· Aquarium Resources
· Aquatic Plants
· Barb Fish
· Betta Fish
· Breeding Fish
· Catfish
· Central American Cichlids
· Cichlids
· Clownfish
· Corals
· Corydoras Catfish
· Discus Fish
· Dwarf Cichlids
· Fish Diseases
· Frogs and Turtles
· Goby Fish
· Goldfish
· Gourami
· Invertebrates
· Jellyfish
· Killiefish
· Lake Victoria Cichlids
· Livebearers
· Malawi Cichlids
· Marine Aquariums
· Marine Aquarium Fish
· Other Fish
· Pleco
· Predatory Fish
· Photography
· Pond Fish
· Responsible Fish Keeping
· Rainbow Fish
· Shark Fish
· South American Cichlids
· Tanganyika Cichlids
· Tetra Fish
· Tropical Fish Food

User Tag List

Results 1 to 10 of 23

Thread: Filter startup?

Hybrid View

  1. #1

    Join Date
    Mar 2013
    Posts
    15

    Latest gifts & ribbons:

    Default Filter startup?


    0 Not allowed!
    Hi, I just ordered an Aquarius tank that came with a filter. In the instructions it just said to take it out of the box, attach the clip and put it on the aquarium so I did. After plugging it in and waiting 30 minutes, nothing happened - didn't start up or anything. The filter is called Mini-Might. Any idea why this is happening?

    Thanks

  2. #2

    Join Date
    Nov 2012
    Location
    Manhattan, Ks
    Posts
    475

    Awards Showcase

    Latest gifts & ribbons:

    ٩(̾●̮̮̃̾̃̾)۶ - korith   

    Default


    0 Not allowed!
    I don't know about your filter but if its a hang on back filter pour water into it to start priming it. Other then I'd turn it off as running a filter dry is very hard on it and look online for a FAQ or other information from the manufacture.
    20 gallon tall: empty
    29 gallon: moderately planted with 9 bloodfin tetra, 1 german blue ram, 11 glow light tetra and 1 BNP
    10 gallon QT: empty

  3. #3

    Join Date
    Mar 2013
    Posts
    15

    Latest gifts & ribbons:

    Default


    0 Not allowed!
    Yeah, it's one of those. How much do I need to pour over it?

  4. #4

    Join Date
    Jan 2009
    Location
    A little further from sanity
    Posts
    9,317

    Awards Showcase

    Latest gifts & ribbons:

    Thanks for the rep friend :) - Compass   Merry Christmas! - rebecca_finny   Thanks for the rep! - AmazonJoe   Happy Holidays. - gadget228   Merry Christmas & Happy New Year! - Plecos   

    Default


    0 Not allowed!
    Fill it to the top. If that doesn't work, check to see if the impeller is properly seated.
    When I go fishing I just throw sharp rocks in the water and wait for the dead fish to float to the top... Kingfisher
    Everything happens for a reason. Sometimes that reason is you are stupid and make bad decisions.

    I think my fish is adjusting well to the four gallon, He's laying on his side attempting to go to sleep on the bottom of the gravel.
    Imitation is the sincerest form of flattery.
    Dear naps, sorry I hated you so much when I was a child... Love me

  5. #5

    Join Date
    Mar 2013
    Posts
    15

    Latest gifts & ribbons:

    Default


    0 Not allowed!
    How do I do that? lol, sorry.

  6. #6

    Join Date
    Nov 2012
    Posts
    93

    Latest gifts & ribbons:

    ٩(̾●̮̮̃̾̃̾)۶ - korith   

    Default


    0 Not allowed!
    I have the same one. There is a line on the filter for the optimal water level...make sure the water is at that level before you plug in the filter. The first time I didn't have the problem you described, but after a water change same problem. First, unplug the filter when you do a water change. After the level is back (new water added after the change), start pouring some of the tank water directly into the top of the filter, after the second pouring, plug in the filter while pouring water over the filter and it should restart.
    As far as the impeller...you will have to take the filter apart. Make sure you pay close attention to how the filter goes back together (especially how the power cord is routed through the plastic guide (only fits one way and how it snaps in is a little weird). Also, make sure to note which way the filter cartridge is facing. The impeller is all the way at the bottom and it is the only part that turns-make sure it can spin freely.
    Try the priming (pouring water into the filter) first, that should work.

    Fee free to ask me if you have any more questions and good luck! What will you be putting in the tank?
    Last edited by Betta113; 03-21-2013 at 10:59 PM.

  7. #7

    Join Date
    Mar 2013
    Posts
    15

    Latest gifts & ribbons:

    Default


    0 Not allowed!
    Does splashing it with a new plastic spoon (water washed and all) count? Not sure what I can usen that's clean.

    I'll be putting a few zebra danios and tetras in it!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •