What about now

(If this works but not the others than your https settings might be a little to strict. This last one is pure http)