PDA

View Full Version : What is wrong with my moss?



Lady Hobbs
01-27-2008, 02:40 PM
Honestly. Don't tell me that I even kill moss!

I had it under 18 watts and it started looking rather crummy so I moved it into the brighter tank and it still is looking pretty sick.

Rue
01-27-2008, 02:58 PM
No idea...I've never even seen moss around here...

Although I think I want some!:thumb:

gm72
01-27-2008, 02:59 PM
Diagnosis: Death. I wonder why it is dying?

Fishalicious
01-27-2008, 03:12 PM
Moss loves to catch up all the grubby free floating muck which stops light getting to it properly even if it is 100 Watts ;) You need to give moss a good shake out every week in the water to get it all lose

Lady Hobbs
01-27-2008, 03:12 PM
I just tore it apart and put smaller pieces on several rocks. Maybe I had it too thick? It looks better underneath the dead stuff. I just trimmed the brown off so we'll see. I'd like to know why it is dying, tho. I would think too much light right now but that doesn't explain why it started doing this in much less light.

*sigh*

Thanks Fishalicious. As always, as big help you are.

Lady Hobbs
01-27-2008, 03:51 PM
Hey Rue. Maybe this guy will share some with you.

http://aqualandpetsplus.com/Plant,125.jpg

cocoa_pleco
01-27-2008, 05:16 PM
Hey Rue. Maybe this guy will share some with you.

http://aqualandpetsplus.com/Plant,125.jpg


haha, thats what my 10g looks like, i put a clump in for the auratus and now its grown so much it looks like a swamp.

lots of people here want a "starter" clump of moss on ads so i give them some

country_boy454
01-27-2008, 11:06 PM
My moss is finally starting to take over the tank. I have it in a ten gallon with the same light it came with. Dunno the wattage. The last couple weeks it has quadrupled in size. I will have to clip it soon. Thats ok though cause I wanted to put it in my 29 gallon!

Algenco
01-27-2008, 11:19 PM
The stuff will take over!! I have well over a pound

Lady Hobbs
01-29-2008, 12:43 AM
LOL Well, I think this needs to go under lower light.

Algenco
01-29-2008, 01:19 AM
don't know whats wrong? Mine is growing like crazy in tanks from 1.5- 2.2 wpg , could your nitrates be too low?

Lady Hobbs
01-29-2008, 02:21 AM
Me .......who always has nitrates at around 5 on a good day? Truthfully, I have no idea what they are. I had 0 for so darned long I ran out of stuff for testing and never bothered to order more. It's like testing for pH when I know it's 7.6 every single day.

But, I do have another Master test kit on my "wish list" at Big Als and will need to be ordering another soon.

The moss on the top was what was brown looking. Underneath is nice and green so maybe I had it too thick on that rock? Not as thick as this mess in the picture I posted, however. :)

Dave66
01-29-2008, 02:30 AM
Me .......who always has nitrates at around 5 on a good day? Truthfully, I have no idea what they are. I had 0 for so darned long I ran out of stuff for testing and never bothered to order more. It's like testing for pH when I know it's 7.6 every single day.

But, I do have another Master test kit on my "wish list" at Big Als and will need to be ordering another soon.

The moss on the top was what was brown looking. Underneath is nice and green so maybe I had it too thick on that rock? Not as thick as this mess in the picture I posted, however. :)

Hobbsy,
Is that Java or Willow Moss?

Dave

crackatinny
01-29-2008, 02:33 AM
I once tried the moss, as people said anyone can grow it, well theres no moss anymore, the Silver dollars loved it:11:

Lady Hobbs
01-29-2008, 03:11 AM
Hi Davey_Doo......Java I believe. I got a lovely big chunk from Algenco that was just beautiful until it met me.